xbns.net
当前位置:首页 >> jEnkins中mAvEn3.3.9不支持jDk7吗 >>

jEnkins中mAvEn3.3.9不支持jDk7吗

1通过jenkins web页面添加git plugin manage jenkins->manage plugins->available中选择git plugin安装, 注意要填写user name和 email地址,否则日后会碰到git tag的错误 2在jenkins使用的机器上创建git用户所需要的公钥 具体步骤参考前面gitjenkins系统设置中没有jdk maven的设置选项安装了

maven3.3.9 对jdk的版本有要求ockorg.apache.maven.pluginsmaven-compiler-plugin2.3.21.61.6

我用的是maven3.3.9,Myeclipse10版本,配置Maven时发现无法选择JDK版本,只能选择默认的JDK1.6,应该是Myeclipse自带的那个,点击Add也添加不上,我电脑上安装的是JDK1.8,是因为maven还不支持jdk1.8吗?

1通过Jenkins web页面添加Git plugin Manage Jenkins->Manage Plugins->Available中选择Git Plugin安装, 注意要填写user name和 email地址,否则日后会碰到git tag的错误 2在Jenkins使用的机器上创建Git用户所需要的公钥 具体步骤参考前面GitJenkins系统设置中没有jdk maven的设置选项安装了

1.Jenkins的安装(最为简单的安装方法)(1)下载Jenkins(一个war文件)(2)cmd运行:java -jar jenkins.war【Jenkins需要IDK1.5以上的版本】Jenkins的默认端口号是8080,以下是Jenkins的安装成功运行的页面:2.Jenkins的配置2.1系统

恩,tomcat7应该太老了,所以不行了

你下载了正确的版本么 没,那是怎样的界面

方法/步骤使用maven的时候,默认会使用1.5版本的JDK,并且也是编译成1.5的,我的电脑里面用的JDK是1.7的,1.8也出来了,没理由还用1.5的吧!所以我手动改成了1.7,郁闷的是,每次 maven-update project 的时候,又变成1.5的了查阅了相关资料后,发现了修改的方法,打开maven安装目录下的 maven--》conf 修改settings.xml,找到profiles节点,在里面添加jdk-1.7true1.71.71.71.7 最后,再次在eclipse中 maven--》update project 就会发现,maven的JDK版本变化了!

首先要搞清楚你的系统的版本,是64位还是32位的再看一下你要打开或者运行的软件是不是支持你的系统,比如说你的系统是win7X64,那么很有可能原来在winxp下面运行的程序在win7X64下是不能运行的一般软件支持哪个系统都会有说明的,你下载软件的时候就找支持你系统的就行了

安装 maven 之前要求先确定你的 jdk 已经安装配置完成.maven是 apache 下的一个项目,目前最新版本是 3.1.0,我用的也是这个.首先去官网下载 maven下载完成之后将其解压,我将解压后的文件夹重命名成 maven,并将它放在 d:\server 目录下,即 maven 最终的路径是:d:\server\maven配置 maven 环境变量:系统变量:maven_home = d:\server\maven用户变量:path = %maven_home%\bin相信大家都有配过环境变量的,详细步骤就不说了,对着把属性名和属性值配上的ok了.

相关文档
网站首页 | 网站地图
All rights reserved Powered by www.xbns.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com